OpenShot 1.1 no se ejecuta en Ubuntu 9.10 Karmic Koala (resuelto)

Ya hemos visto en Slice of Linux cómo instalar OpenShot desde el repositorio PPA (puedes consultar el artículo Nuevo repositorio para OpenShot).

Sin embargo, hoy lo he instalarlo en mi portátil con Karmic de 32 bits y, al ejecutarlo desde Aplicaciones > Sonido y vídeo > OpenShot Video Editor, no obtenía ninguna respuesta.

La forma de averiguar qué estaba ocurriendo fué ejecutarlo desde la Consola (Aplicaciones > Accesorios > Terminal). Escribí el siguiente comando:

openshot

y obtuve esta respuesta.   

--------------------------------
   OpenShot (version 1.1.0)
--------------------------------
*** ERROR: MLT Python bindings failed to import ***
*** ERROR: MLT Python bindings failed to import ***
Exception in thread Thread-1:
Traceback (most recent call last):
  File "/usr/lib/python2.6/threading.py", line 525, in __bootstrap_inner
    self.run()
  File "/usr/lib/pymodules/python2.6/openshot/classes/thumbnail.py", line 170, in run
    mlt.Factory().init()
NameError: global name 'mlt' is not defined

-------------------------------------------------------
Error:  OpenShot has not been installed in the Python path.
(Both the site-packages and /usr/share/openshot folders were checked)

Use the following command to install OpenShot:
  $ sudo python setup.py instal

Después de buscar un poco por Internet, he encontrado la solución en la propia página de OpenShot. Consiste en escribir en la consola la siguiente orden: 

sudo ln -s $(ls -C /usr/lib/libmlt++.so.* | cut -f 1 -d' ') /usr/lib/libmlt++.so.2

Espero que disfrutes de este estupendo programa.

Anuncios

10 Responses to “OpenShot 1.1 no se ejecuta en Ubuntu 9.10 Karmic Koala (resuelto)”


  1. 1 José Cabo Jueves, 11 marzo 2010 en 3:06 pm

    Hola,

    Realmente el problema está con un conflicto con la aplicación kdenlive en el paquete MLT (creo…). Haciendo un aptitude purge kdenlive openshot (Y quitar el repositiorio de kdenlive) y después instalando openshot se debería solucionar.

    No he probado a usar ese enlace simbólico pero imagino que funcionará.

    Un saluditoooo ^^

  2. 2 tecnoubuntu Jueves, 11 marzo 2010 en 3:31 pm

    De echo, creo que José tiene razon yo no tengo el repositorio de Kdenlive y openshot me funciono perfectamente en Ubuntu 9.10 64x.
    Aunque siempre es bienvenida una ayuda si es que llega a sucedernos.

  3. 3 Ramón Viernes, 12 marzo 2010 en 3:28 pm

    Funciona muy bien el comando. Gracias por el aporte

  4. 4 Epifanio Martes, 16 marzo 2010 en 9:15 pm

    Buenas noche gente.

    Llevo dos dias sin poder utilizar el programa openshot, de buenas a primeras no puedo abrirlo. He puesto openshot en el terminal y sale lo siguiente:

    epifanio@epifanio-laptop:~$ openshot
    ——————————–
    OpenShot (version 1.1.1)
    ——————————–
    A new frmMain has been created
    Traceback (most recent call last):
    File “/usr/bin/openshot”, line 57, in
    main()
    File “/usr/lib/pymodules/python2.6/openshot/openshot.py”, line 57, in main
    form1 = MainGTK.frmMain(project=current_project, version=info.SETUP[‘version’])
    File “/usr/lib/pymodules/python2.6/openshot/windows/MainGTK.py”, line 274, in __init__
    self.project.RefreshXML()
    File “/usr/lib/pymodules/python2.6/openshot/classes/project.py”, line 233, in RefreshXML
    self.form.timelinewindowRight.window.set_cursor(gtk.gdk.Cursor(150))
    AttributeError: ‘NoneType’ object has no attribute ‘set_cursor’

    Agradeceria que alguien me comentara como solucionar el problema, ya que uso frecuentemente este programa.
    Saludos y gracias.

  5. 5 Garrancha Jueves, 1 abril 2010 en 3:41 pm

    ESTE PROBLEMA SALE CONSTANTEMENTE DESPUES DE UTILIZARLO UNAS SEMANAS, MOTIVO… SOLUCIONES….SALUDOS.

    OpenShot (version 1.1.2)
    ——————————–
    A new frmMain has been created
    Traceback (most recent call last):
    File “/usr/bin/openshot”, line 57, in
    main()
    File “/usr/lib/pymodules/python2.6/openshot/openshot.py”, line 57, in main
    form1 = MainGTK.frmMain(project=current_project, version=info.SETUP[‘version’])
    File “/usr/lib/pymodules/python2.6/openshot/windows/MainGTK.py”, line 274, in __init__
    self.project.RefreshXML()
    File “/usr/lib/pymodules/python2.6/openshot/classes/project.py”, line 233, in RefreshXML
    self.form.timelinewindowRight.window.set_cursor(gtk.gdk.Cursor(150))
    AttributeError: ‘NoneType’ object has no attribute ‘set_cursor’

  6. 6 DavidOtero Sábado, 17 julio 2010 en 10:47 pm

    Buenas, estoy usando Ubuntu Lucid e instalo Openshot desde el Centro de Software, pero al ejecutarlo desde Aplicaciones>Sonido y video>Openshot aparentemente no ocurre nada. Al ejecutarlo en la terminal dice lo siguiente:

    ——————————–
    OpenShot (version 1.1.3)
    ——————————–
    Process no longer exists: 4964. Creating new pid lock file.
    A new frmMain has been created
    Fallo de segmentación

    A ver si alguien me puede aportar alguna solución, gracias de antemanos.

  7. 7 javiermisol Miércoles, 15 septiembre 2010 en 6:48 pm

    Parece ser que hay problemas con el libcairo2

    Esta ya bien claro ya que en el otro pc tengo Ubuntu 10.04 y funcion y el libcairo2 1.8.10 y en el que trabajo ahora esta la 1.9.6-6, si intento desinstalar la ultima version para poder volver a usar la libcairo2 1.8.10 dejo el sistema ubuntu desmantelado y dejaria de ser funcional ya que otras aplicaciones depende de esta librerias… ya que se debe a una actualizacion forzada por aplicaciones por repos a terceros, esto ultimo como una conclusion propia.

    De momento si necesito editar algo me ire al otro pc una solucion temporal hasta que salga una nueva revision o version nueva siguiente.

  8. 8 alemcito Viernes, 17 septiembre 2010 en 8:18 am

    respondiendo a Garrancha yo tmb tuve ese problema y lo resolvi eliminando la carpeta .openshot de la carpeta personal, esto es en caso de ubuntu-linux, yo personalmente no uso windows pero debo suponer que dicha carpeta se encuentra en mis documentos creo que asi se llama la carpeta no … bueno suerte y exitos

  9. 9 james8392 Martes, 21 diciembre 2010 en 8:36 pm

    Bueno amigos yo tenia el mismo problema pero lo resolvi instalando openshot desde repositosio y me funcian muy bien deveras =D=D=D

    Aca los dejo el link
    http://www.openshot.org/ppa/

    Abran el terminal en
    Aplicaciones->Accesorios->Terminal

    Ahi tambien los tinen ya solo copienlo como esta ahi cada fila diferente empezando con sudo por fila =D y lo pegan con Shisft+Instert
    Ubuntu 9.10 (Karmic) o superior

    sudo add-apt-repository ppa:jonoomph/openshot-edge
    sudo apt-get update
    sudo apt-get install openshot openshot-doc

    Mi sistema es ubunto 10.04

    Bueno espero que le funcione a mi me funciona muy bien es un bueno programde deveras saludos PNAS =D

  10. 10 roberta perez Lunes, 2 mayo 2011 en 6:22 am

    saludos a todos…he leido la pagina y me interesa saber si alguno de ustedes les aparece el mensaje como ami y si alguien pudo corregirlo gracias por la ayuda… help penShot (version 1.3.0)
    ——————————–
    Traceback (most recent call last):
    File “/usr/bin/openshot”, line 57, in
    main()
    File “/usr/lib/pymodules/python2.6/openshot/openshot.py”, line 65, in main
    app = frmMain(project=current_project, version=info.SETUP[‘version’])
    File “/usr/lib/pymodules/python2.6/openshot/windows/MainGTK.py”, line 315, in __init__
    self.project.RefreshXML()
    File “/usr/lib/pymodules/python2.6/openshot/classes/project.py”, line 283, in RefreshXML
    self.form.timelinewindowRight.window.set_cursor(gtk.gdk.Cursor(150))
    AttributeError: ‘NoneType’ object has no attribute ‘set_cursor’


Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s




Síguenos en Twitter

 

Sitios amigos:

Si has leído nuestro Acerca de, sabes que no publicamos ningún artículo práctico que no hayamos probado. Aún así, no podemos garantizar que en tu sistema funcione como en el nuestro.

Esta página no es de soporte. Compartimos lo que sabemos, pero si resolviésemos todas las dudas que recibimos, no podríamos hacer artículos nuevos. Por eso, si alguien plantea un problema, y sabes la respuesta, siéntete libre para comentarla.

Si tienes una duda y no obtienes respuesta, puedes recurrir a sitios específicos como ubuntu-es.org o Linux Q.

Creative Commons License
Esta obra está bajo una licencia de Creative Commons.


A %d blogueros les gusta esto: